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INTRODUCTION 

Welcome to Advance Design 

From modeling to the structure calculation, result post-processing and 

structure optimization, Advance Design offers a complete environment for 

the static and dynamic analysis of 2D and 3D structures using the finite 

elements method. 

This software also provides advanced design capabilities for steel, 

reinforced concrete and timber structures. The verification of steel 

elements starts from an initial dimensioning and may continue with several 

successive optimizations. The reinforced concrete design determines, by 

several available methods, the theoretical reinforcement area and the 

reinforcement ratios of concrete elements. 

Advance Design is a new generation analysis software, improved with 

powerful and innovative features: 

 Complete integration of finite elements / reinforced concrete / 

steelwork / timber analysis modules; 

 Possibility to perform various tasks, such as: 

- Model your structure with the assistance of various CAD 

tools (workplane, coordinate systems, snap modes, etc.) and 

CAD functions (extrude, subdivide, trim, extend, create 

symmetries, etc.); 

- Input structure assumptions (materials, cross sections, 

loads, analysis types); 

- Create a mesh using two powerful mesh engines (Advanced 

and Standard Mesh); 

- Calculate the structure using a new generation solver 

engine; 

- View the results choosing from a large set of visualization 

options; 

- Calculate and optimize reinforced concrete, steel and timber 

structures according to standard regulations; 

- Generate calculation reports using a variety of predefined 

result tables. 
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About this guide 

This guide provides a description of the main functions and interface of 

Advance Design, and, through a few small examples, the program's 

working process. The examples follow each description of Advance Design 

functions. 

This guide is a brief introduction of Advance Design and not all of its 

features are described. For detailed information regarding the program 

functions, refer to Advance Design Help, which is accessible from the 

interface. 

The examples presented in this guide are for learning purpose and do not 

conform to specific standards. 

Where to find information? 

Advance Design has an online help system that offers step-by-step 

instructions for every function. 

The online help is available from the Advance Design interface with the 

following commands: 

 Menu: select Help > Online Help... 

 From keyboard: press <F1> 

Contacting technical support 

GRAITEC technical support is available by phone, fax or email. To reach 

GRAITEC technical support: 

 Ribbon: Manage tab: click Technical support to send an email 

to GRAITEC. 

 Menu: select Help > Technical support. A template email is 

sent to the technical support team who will quickly solve the 

problem and provide a precise answer. The model of the current 

project is automatically archived and attached to the message. 
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WHAT IS ADVANCE DESIGN? 

Advance Design, structural analysis software designed for the civil 

engineering field, offers a complete and fully integrated environment from 

the structure modeling to the result post-processing and structure 

optimization. 

It provides a complete range of functions specialized in advanced CAD 

modeling, meshing, calculation, verification and optimization of reinforced 

concrete, steel and timber structures, result post-processing and 

generating high quality reports. 

The study of a project in Advance Design environment is designed in four 

operating modes: Model, Analysis, Design, and Document. 
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INSTALLING ADVANCE DESIGN 

System requirements 

To successfully install Advance certain requirements must be met. 

For complete details, access the Installation guide or 

www.graitec.com/advance-installation. 

Advance Design installation 

Before installing Advance Design: 

 Make sure you have administrator rights under Windows. 

 Close all open applications. 

Proceed with the installation as follows: 

1. Access Graitec Advantage on your browser and log in with your 

credentials. Find product releases sorted by type and year, under the 

Downloads section.  You can either download a DVD ISO image of the 

software or download and run the online installer. 

If the AutoPlay tool on the computer is switched off and thus the setup 

does not start automatically, use the Run command: 

- From the Windows menu, select: Start > Run. 

- In the Run dialog box, click Browse to select the 

SetupAdvance.exe program. Click <OK>. 

2. Select the installation language and click Install products. 

3. On the next screen, select Advance Design and click Next. 

4. Read the license agreement. Select I accept to agree to the specified 

terms and click Next to continue. 

5. On the next screen, select the interface language and the installation 

path. 

- To select the interface language, click Customize. In the next 

dialog box, select the interface language and the local settings 

for each installed application and click <OK>. 

- To change the destination path, click . In the next dialog box, 

enter a path or select a different folder in which to install 

Advance and click <OK>. 

6. Click Install to start the installation. 

7. Wait a few moments while Advance Design is installed on the 

computer. Click Exit when the installation is complete. 

https://graitec.info/Advance2021/Documentation/Advance-Installation-Guide-2021_EN.pdf
https://www.graitec.com/advance-installation/
https://advantage.graitec.com/en-US/
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After installing Advance Design, a license is required to use the software. 

The license is activated based on the activation code and the serial 

number provided by the dealer. Once the license is successfully activated, 

the software can be used according to the license rights. 

Without the authorization code, a temporary license for 15 days may be 

installed. 

The activation process starts on launching Advance Design. Follow the 

procedure described in the Installation guide. 
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STARTING ADVANCE DESIGN 

Advance Design can be launched using various methods: 

 From the Windows Start menu, select Programs > Graitec > 

Advance Design. 

 Double click the Advance Design icon on the desktop. 

 To start another work session simultaneously: 

 Double click an existing .fto file in its disk location. 

 Double click the Advance Design icon on the desktop. 

Project management 

Each time Advance Design is launched, a wizard helps the user to create 

and configure new projects and to manage the existent ones. 

 Example: Configuring a new project 

1. On the New tab of the starting wizard, click Configuration. 

2. In the "Localization settings" dialog box make the following settings: 

- Select the language to be used for the interface and the 

calculation reports; 

- Select the Combinations standard: EC0 - General; 

- Select the Seismic standard: EC8 - General; 

- Select the Climatic standard: EC1 - General; 

- Select the Reinforced Concrete standard: EC2 - General; 

- Select the Steelwork standard: EC3 – General; 

- Select the Timber standard: EC5 – General. 
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ADVANCE DESIGN ENVIRONMENT 

Advance Design offers a complete environment for modeling, analysis, 

design, and result post-processing - all fully integrated in the same 

interface. 

1.  3.   6. 

2. 

  

4. 

5. 

10. 9. 8. 7.  

1. Quick Access Toolbar 

This toolbar contains a set of commands specified by the application or 

selected by the user. 

2. Menu button 

You can access the program commands using the menu button available 

in the top left corner. The menus are listed from top to bottom considering 

the order of the work process steps. 
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3. Ribbon 

Each tab in the new Advance Design ribbon allows access to several 

panels of commands. You can display or hide the tabs and their panels in 

the ribbon, by double clicking on each tab. 

4. Toolbar 

Different types of commands are grouped in toolbars, which can be easily 

displayed1 and positioned (i.e., floating or docked) by drag-and-drop in the 

application environment. The toolbars that are active only in certain steps 

of the project (such as Modeling, Analysis Settings, Analysis - F.E. 

Results, etc.) are automatically displayed or hidden, to optimize the 

workspace during the work process. 

5. Project Browser 

The project browser represents the control center of Advance Design that 

groups all the components of the model in a tree structure of elements and 

provides easy access to the project's working modes: "Model", "Analysis", 

"Design", and "Document". 

The working mode is changed by clicking the corresponding icon located 

on the upper side of the project browser:   . 

Each item of the project browser has a context menu that provides access 

to different commands specific to the current step of the project. The 

project browser contents differ for each working mode: 

 Model mode: groups the structure elements (which can be 

organized in systems and sub-systems), the loads (organized in 

family of cases and load cases), analyses settings (load 

combinations, envelopes, analyses types) and saved model 

views. 

 Analysis mode: provides the management of analysis cases, 

analysis types, saved analyses, and post-processing views. 

 Design mode: only becomes active after an analysis is 

performed, and an element is selected in the Design tab of the 

Project Browser. 

                                                                    
1
  Starting with version 2016, the toolbars in Advance Design can be displayed by 

selecting Display > Toolbar from the menu button and choosing the desired 
toolbar. 
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 Document mode: provides access to all documents generated 

during the work process: reports, memorized views and AVI 

files. 

6. Properties window 

The attributes of all the model entities can be viewed and modified in the 

properties window. The properties are displayed in a tree structure in 

various categories. The properties window is displayed dynamically, when 

an element (or a drawing tool) is selected, and provides access to the 

common properties of a selection of elements of the same type. 

7. Status bar 

The status bar displays information regarding the program status during 

different phases of the project. It also contains buttons that provide access 

to the configuration of certain parameters: snap modes, objects tooltips 

content, current coordinate system, and working units. 

8. Graphic area 

The graphic area represents the design area of the application; it provides 

an easy and intuitive use of CAD commands and a realistic rendering of 

the model. Each element of the graphic area has a context menu that 

provides quick access to different specific commands (e.g., select, 

generate elements on selection, display / hide elements, etc.). 

The graphic area can also be split into several viewports (from one to four); 

each of these viewports can have different display settings and a different 

view point (i.e., zooms on a certain part of the structure, realistic or 

simplified rendering, etc.). 

The default workplane of the drawing area assists in the structure 

modeling. The workplane's parameters can be defined and the workplane 

is easily hidden or displayed during the work process. 

9. Command line 

The command line informs about the status of an action, assists in the 

drawing process, informs about errors, etc. It contains three tabs: 

 Information: displays the status of the current operations. 

 Errors: displays warnings and error messages. 
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 Edit: allows the dialog between user and application; provides 

the option to draw / modify objects by typing parameters in the 

dialog area of the command line. 

10. Coordinate system 

The global coordinate system is represented by a three axes symbol 

permanently displayed in the graphic area. It is also possible to create one 

or several user-defined coordinate systems (Cartesian or polar). 

The program interface is intuitive and enhanced for an easier manipulation 

of its different components and commands (i.e., advanced docking, 

undocking, auto-hiding, tabbing, etc.). 
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MODELING: CREATING THE DESCRIPTIVE MODEL 

The structure modeling may be done entirely with the use of various CAD 

tools via the graphic area, where a 2D or 3D representation of the model 

can be visualized at any time. 

The various zoom and view commands (e.g., rotate around the model, 

predefined views, etc.) provide fast and easy manipulation of the graphical 

elements. 

Advance Design elements 

Advance Design provides a complete library of structure elements, 

supports and geometric entities. 

 

Example Element type 

 

Linear elements (bar, beam, short beam, variable beam, 

tie, strut, cable) 

 

Planar elements (membrane, plate, shell, plane strain, 

steel deck) 

 

Supports (point, linear and planar supports, which can be 

rigid, elastic or traction only / compression only) 

 

Load areas: elements used for the distribution of loads on 

the supporting elements 

 
Points 

 
Lines and polylines 

 
Grids 

 
Dimension lines 
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Creating elements 

Elements are drawn in the graphic area using the keyboard (by typing 

coordinates on the command line) or the mouse, relative to the 

workplane's points or to existing entities. Advance Design also provides 

various automatic drawing tools (e.g., generate elements on selection, 

portal frames and vaults generators, etc.). 

 Example: Creating structure elements 

1. Home tab, Linear & Planar panel, select Linear element. 

2. In the graphic area (XZ plane): click to define a column at 0 0 

coordinates for the first extremity and 0 7 for the second one. 

 
3. With the linear element drawing tool still active, type on the command 

line the coordinates for the second column: 12 0 for the first extremity and 

12 7 for the second one. Input a space between coordinates and press 

Enter after each extremity definition. 

 
4. Draw the upper beam between the two columns, using the "Extremity" 

snap mode: 
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5. Draw a 3 meters high column placed at 6 0 XZ coordinates. 

 
6. Create a storey beam: with the linear element drawing tool still active, 

press <Alt + S> to access the snap modes dialog box; select the 

perpendicular snap and draw the beam as shown below. 

 
7. On the Home tab, Supports panel, select Rigid Point; in the drawing 

area, click the bottom extremity of each column, to create supports. 

 

Definition of element properties 

The attributes of each element are defined in the properties window (e.g., 

name, ID, and different parameters). By default, the properties window 

appears when an element is selected and auto-hides when it is empty.’ 

 Example: Defining the element properties 

1. Click the two columns and the beam of 

the main portal frame to select them. 

 
2. In the properties window make the 

following settings: 

-   Material: C25/30; 

-   Cross section: R60*90. 
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3. Select the storey column, and, in its 

properties window, select the S235 material. To 

define the element cross section, click  to 

access the section library and select IPE200 

from the "European Profiles". 

 
 

Proceed in the same way to define the material and cross section for the 

storey beam: S235 - HEA200. 

Systems of elements 

The structure elements that are created (also geometric elements, help 

entities, etc.) are stored in the project browser, in the Model mode. The 

project browser's context menus for each of its items provide rapid access 

to different modeling commands and an advanced management of the 

elements (i.e., hide / display, select, delete, group in systems, etc.). 

The system concept helps define the behavior of different groups of 

elements (e.g., assign design templates). Different operations are easily 

performed on a group of elements using their system's context menu 

commands. The level function available in the system's properties window 

defines the level settings and thus creates faster and easier structure 

elements on different altitudes (levels): a column using one click, a wall 

using two clicks. 

 Example: Creating systems of elements 

1. In the project browser, right click Structure 

and select Systems management / Create a 

subsystem from the context menu. 

2. Type the system name: Portal frame. 

3. Select the Portal frame system, and using 

the steps described above, create the following 

subsystems: Columns, Beams, Supports, and 

Load Areas. 

4. Create a Storey system under Structure 

with the Columns, Beams, Slabs and 

Supports subsystems.  
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5. In the project browser, select the two 

columns of the portal frame and drag-and-drop 

them to the Portal frame > Columns system. 

 
Using the same method, place all the elements of 

the model in the corresponding systems. 

 

CAD functions 

The graphical input of the model is very easy and accurate, using the 

advanced CAD commands. Easily copy (i.e., by rotation, translation, or 

symmetry), move, extrude, trim or extend, subdivide, cut, create openings, 

etc. using a large set of commands accessible from various locations (i.e., 

menus, context menus, toolbars, etc.). 

 

 Example: Copying elements 

First, define a 3D view of the workplane: on the Home tab, Views panel, 

click  (or press <Alt + 6>). 

1. Press <Ctrl + A> to select all the elements of the model. 

2. Right click the drawing area and select Copy (or press <Insert>). 

3. In the "Multiple copy" dialog box, define the copy parameters: 

-   Copy by Translation; 

-   Vector: 0 6 0; 

-   Number: 3. 

4. Click Preview to display the result. 

5. Click Copy to apply. 
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Create the rest of the storey elements: 

- In the project browser, select the Storey > Beams 

subsystem. 

- Select the linear elements drawing tool and draw two 

longitudinal beams (S235 with HEA200 cross section).  

-   Select the first transverse beam and make 2 copies in the 

0 2 0 direction. 

-  Select the two copied beams and define, in their properties 

window, an S235 material and an IPE200 cross section.  

-  Make 2 copies of the selected beams in the 0 6 0 direction. 

 

Generating Loads 

Loads are generated and organized using the project browser. Loads are 

grouped in the project browser under "Loading" in load cases (i.e., self 

weight, static, seismic, etc.) and case families (permanent loads, live 

loads, snow, wind, temperatures, etc.). Each case family may contain 

several load cases, and each load case may contain several loads. 

 
Loads are generated via the graphical input, using the 

load creation tools available on the Home tab - Load 

case & Loads panel, in the project browser or menus. 

The automatic tools (i.e., pressure loads generator, 

climatic loads generator, loads on selection, etc.) can 

also be used. 

 

The parameters of loads, load cases and case families 

are defined in their properties windows. The loads are 

managed using their context menu commands in the 

project browser. 

Once loads have been defined, load combinations and 

envelopes can be created (using the project browser or 

the Analyze menu commands). 

Using the combinations manager, combinations are 

manually created and the standard combinations 

available in Advance Design are loaded. 
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 Example: Generating loads 

Generate the self weight 

From the menu, select Generate > Load > Dead Loads. The "Dead 

loads" family and a dead load case are automatically created in the project 

browser. 

Create a live load 

First, create the storey slab. In the project browser: 

select the Storey > Slabs subsystem. On the Home 

tab, Linear & Planar panel, select Planar element and 

draw the slab as shown. 

In the slab's properties window define: 
   

- Material: C25/30. 

- Thickness: 15 cm. 

- Design experts > Cracking > Reinforcement, click Definition 

>  and make the following settings: 

 
1. In the project browser: right click Loading and 

select Create a case family from the context menu. 

2. In the displayed window, select Live Loads. 

3. Click <OK>. 

A live loads family and a corresponding case are 

created in the project browser. 

4. Select the 2Q live load case in the project 

browser. 

5. In the drawing area, select the storey slab. 

6. Right click and select Loads / selection from the 

context menu. 

7. The planar loads properties window is 

automatically displayed: input the loads intensity on FZ: 

- 5 kN. 

8. Click <OK>. 

 

 

Generate snow loads 

First, create two beams and a load area on the portal 

frame: 

-   In the Portal frame > Beams subsystem create two 

longitudinal portal frame beams, using a C25/30 

material and an R40*60 cross section. 
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-   In the project browser: select the Portal frame > 

Load Areas subsystem. Select the two longitudinal 

beams; right click and select Load Areas / selection 

from the context menu. On the Home tab, Render 

modes panel, click  to enable the "Axes" rendering 

mode; this provides a view of the span direction on 

load areas. In the load area properties window: set the 

span direction towards the longitudinal beams, 

considering the load area's local axes. 

 

 

 

1. In the project browser: right click Loading and 

generate a snow family using the same steps described 

above. 

A snow family and a snow load case are created in the 

project browser. 

2. In the snow family properties window: 

- Enter 0.52 kN/m² in the "Snow load" field. 

- Enter 250.00 m in the "Altitude" field. 

3. To automatically generate the snow loads on the 

load area, select Generate > Load > Climatic loads 

from the menu. 

 

 Example: Creating load combinations 

 

1. In the project browser, right click 

Combinations and select Properties 

from the context menu. 

2. In the "Combinations" dialog box, 

click Simplified Comb. 

3. Define the live loads and snow 

loads as predominant actions. 

4. Click Generate. 

 

Defining analyses 

During the modeling step, Advance Design provides commands for 

defining several types of analyses (i.e., modal, buckling, static nonlinear) 

and also for the concrete and steel design settings. 
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Access the Settings menu to select the desired 

analysis. For each type of analysis, a default 

analysis case is also automatically created. 

Manage analyses using the project browser's 

commands. View and select the created analyses 

with the project browser. 

The analyses cases parameters are defined in the 

properties window. 

 

 

 

 Example: Defining a modal analysis 

1. Menu: select Settings > Modal Analysis. 

2. In the project browser, a modal analysis family and the "Modes" case 

are placed in the "Settings" group. Select the "Modes" case to display its 

properties window. 

3. Define the modes' parameters: 

-    Number of vibration modes: 10 

-  Masses definition: select masses obtained by combining static loads 

from the drop-down list and, in the "Combinations" field below, click  to 

access the masses combinations dialog box. Define here the fol lowing 

combination: 1*1G + 0.6*2Q. 

 

 

 

 
-     Mass percentage on Z: 0 %. 
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Model verification 

At any time during the modeling step, the model's coherence and integrity 

can be verified with the verification function. Access the Analyze > Verify 

command or click  (Verify) on the Home tab. If there are errors or 

warnings, they are displayed on the command line. 
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ANALYSIS: MESHING AND CALCULATION 

In the next step, after the verification of the model's coherence and validity, 

the program creates the analysis model. The structure meshing and the 

model calculation are performed using the defined analyses (i.e., finite 

elements calculation and concrete / steel verification). 

Creating the analysis model 

To mesh and calculate the structure, it is necessary to create the analysis 

model. Once the model's validity is verified, access the Analyze > Create 

the analysis model command, or, in the project browser, click . 

A wizard provides 

options to combine 

the desired operations 

(i.e., verify, mesh, 

finite elements 

calculation, reinforced 

concrete calculation, 

etc.) into a calculation 

sequence that is 

automatically 

performed. 

 

The analysis model's components are 

controlled and viewed in the Analysis mode in 

the project browser. The available context 

menu commands for each element of the 

project browser manage the analysis 

operations. 

 
 

 

 

 

 

 



ADVANCE DESIGN Starting Guide 

25 

 

After the analysis model creation, 

new panels and commands are 

available (e.g., the Analysis Model 

panel from the Analysis tab), while 

the modeling tools are inactive.  

Meshing 

Two different mesh engines are available in Advance Design: "Grid" and 

"Delaunay". 

The finite element meshing is performed using the global mesh settings 

(defined via the Options > Mesh command) and the mesh parameters 

defined for each element (available in the properties window). The mesh 

parameters of each element are defined using the simplified method (i.e., a 

meshing density along each of the local axes) or the detailed method (i.e., 

a meshing density for each of the element's sides). 

 Example: Defining the model meshing 

 

Create the analysis model 

and the model meshing 

1. In the project browser, 

click  to access the 

"Calculation sequence" 

dialog box. 

2. Select Mesh and click 

<OK>. 

  

Advance Design creates the analysis model and automatically performs the 

model meshing. 

 

Modify the mesh density 

1. From the menu, select Options > Mesh. 

2. In the "Mesh options" dialog box, modify 

the mesh density: in the "Element size by 

default" field, input 0.5 meters. 

3. Click <OK>. 
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Recreate the mesh 

On the Analysis tab, Analysis Model panel, select 

Mesh. 

The meshing is modified according to the global settings.  

Calculation 

After meshing, Advance Design is 

ready to calculate the model. The 

"Calculate" command provides 

access to the "Calculation 

sequence" dialog box, where the 

calculations to perform are selected. 
 

Finite elements calculation 

A powerful finite elements engine performs the model calculation 

according to the structure settings: 

 Defined analyses (static and dynamic calculation, linear and non-

linear analyses, large displacements, generalized buckling, etc.). 

 Finite elements parameters of structure elements (defined in the 

properties window). 

Before the calculation, it is possible to 

select the elements to calculate and the 

type of results to obtain, for optimizing the 

calculation speed and the memory usage. 

 

 

 

 

 

During the analysis step, it 

is possible to specify the 

analyses to calculate (using 

the project browser 

commands). 
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Advance Design can group analyses in 

calculation phases and calculate them step 

by step (allowing property modifications for 

each phase). 

 

Reinforced concrete calculation 

The reinforced concrete engine calculates the reinforcement of concrete 

elements by serviceability limit states (ELS) and ultimate limit states (ELU 

and ELUA) and verifies the concrete cross sections using interaction 

curves. 

The reinforced concrete calculation is performed only if the regulatory load 

combinations are created and the finite elements calculation was run. The 

reinforced concrete calculation considers the global and local concrete 

design settings: 

Global concrete settings  Local concrete settings 

Pertains to the calculation methods of 

reinforced concrete, the columns 

verification, reinforcement and 

buckling parameters, etc. 

 The local concrete design settings 

are defined in the properties 

window of the appropriate 

elements. 

 

 

 
 



ADVANCE DESIGN Starting Guide 

28 

 

Steel calculation 

Advance Design provides a steel calculation engine, which performs the 

calculation of steel elements according to standard regulations. The steel 

expert verifies deflections, the cross section's resistance, the element's 

stability according to second order effects (buckling and lateral-torsional 

buckling), and optimizes the steel shapes. 

The steel calculation is performed only if the standard load combinations 

are created and the finite elements calculation was run. 

The steel calculation considers the global and local steel design settings: 

Global steel settings  Local steel settings 

Pertains to the steel calculation 

methods, the optimization criteria, the 

buckling calculation methods, etc. 

 The local steel design settings are 

defined in the properties window 

of the appropriate elements. 

 

 

 
 

Note: After the calculation, the results can be viewed and the element 

parameters modified, if necessary. The desired calculations can 

be iterated until the appropriate results are obtained. 

  



ADVANCE DESIGN Starting Guide 

29 

 

 Example: Running a complete calculation sequence 

1. From the menu, select Analyze > 

Calculate. 

2. In the "Calculation sequence" dialog 

box, select: 

- Finite elements calculation, 

- Reinforced Concrete calculation, 

- Steel calculation. 

3. Click <OK> to launch the selected 

operations. 

 

The command line displays the 

performed operations and a message 

when the calculations are done.  
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RESULTS POST-PROCESSING 

The phase following the model calculation, also called the post-processing 

step, displays the results on the graphical model or as calculation reports, 

result curves on the selected elements, etc. 

Graphical visualization of results 

A new set of tools and commands are active during the results post-

processing step. They provide different modes to display the desired 

results. Several results visualization commands are available: 

 On the panels in the 

Results tab, which 

appear automatically 

once the 

corresponding 

calculation is done. 

 

  

 From the element's context menu: it is 

possible to display in the graphic area the 

results on selection. When a selection is 

not defined, the results are displayed on 

the entire structure. 

      
  

 Using the results 

configuration dialog box, 

that provides a detailed 

configuration of results 

display. Different 

visualization modes are 

available: colors, values, 

deformed shape, iso-

values, iso-regions, 

vectors, etc. 
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 Example: Creating a graphical post-processing of FE results 

View the displacement results on the storey slab 

1. First, right click in the graphic area and disable Display nodes from 

the context menu. Define a top view of the workplane: press <Alt + 3>. On 

the FEM Results panel, select the Displacements result type, the D 

planar elements results and the combination no. 101. Click  to perform 

the post-processing. 

2. Define a (-1, -1, 1) view of the workplane: on the Home tab, Views 

panel, click . In the result settings dialog box - Options tab: select 

Display results on the deformed and Automatic scale of the deformed. 

 

 
3. Right click the graphic area and deselect Display the mesh from the 

context menu. 

4. Open the results configuration dialog box (press <Alt + Z>), access the 

Options tab and select Extreme values. 

View forces results on the concrete linear elements 

1. Select the concrete elements using the selection by criteria: press <Alt 

+ S>; in the "Elements selection" dialog box, access the Materials tab and 

select C25/30. Click <OK> to apply. 
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2. On the FEM Results panel, select the Forces result type, the My 

linear elements results and the combination no. 101. Click  to perform 

the post-processing. 

 

 
 

View stresses on steel elements 

First, right click the drawing area and select Cancel selection from the 

context menu. 

1. Define a new selection by criteria: press <Alt + S>; in the "Elements 

selection" dialog box, access the Materials tab and select S235. Click 

<OK> to apply. 

2. On the FEM Results panel, select the Stresses result type, the Sxx 

linear elements results and the combination no. 101. Click  to perform 

the post-processing. 

 

 
To clear the results displayed on the screen: hold down the <Esc> key for 

a few seconds. 
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Result curves 

Different results (i.e., FE results as displacements, forces, stresses and 

concrete reinforcement area) can be viewed using the "Result curves" 

command available in the post-processing step of the project. 

Result curves can be obtained on linear and planar elements using section 

cuts. The result curves diagram is configured using various options 

available from the diagram's dialog box. The diagram can be saved as an 

image or it can be printed using specific commands. 

 Example: Displaying result curves on a section cut 

First, create a section cut: 

- Right click the drawing area and select Generate an 

entity > Create a section cut from the context menu. 

- Draw the section cut on the length of the storey slab as 

shown in the figure. 
 

Then, select the analyses displayed on the curve and view the results: 

1. Press <Alt + Q> to access the "Analyses and combinations" dialog 

box. 

2. On the Forces tab click 

None to unselect all loads 

combinations, and then 

select only the 101 loads 

combination. 

 

3. Select the section cut. 

4. Click  in the Results tab, 

Post-Processing panel. The 

default result curves (Mxx and 

Myy) for the selected analyses are 

automatically displayed. 
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Stresses diagrams 

The analysis of the stresses distribution on a given section is performed 

using the section stresses command. A stresses diagram is obtained. The 

diagram dynamically displays the stresses results on each point of the 

linear element. 

 Example: Displaying a stresses diagram 

1. Select the storey beam on which to display the section stresses 

results: 

-    Position the mouse cursor above the desired beam; the tooltip 

displays the details of the element focused by the cursor. 

-    Press the <Tab> key to snap to different elements placed on the 

cursor trajectory; when the cursor focuses the beam of interest (i.e., 

S235 material, HEA200 cross section) - click to select it. 

 
2. From the menu button, select Analyze > Cross Section Stresses. 

The sections stresses diagram is displayed in a new window. Use the 

slider to view the stresses on each point on the beam's length. 
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Post-processing animation 

An animation can be created in Advance Design, starting from the 

graphical results post-processing, following the results distribution and the 

deformed shape of the structure. 

The Animation panel in the Utilities tab provides 

access to all necessary commands for creating and 

recording animations.  
 

 Example: Creating a post-processing animation 

1. On the FEM Results panel, define the following results post-

processing: 

-    Select the Eigen modes result type. 

-    Select Eigen mode 3 from the analyses drop-down list. 

-    Click  to perform the post-processing. 

2. Define a front view of the workplane: on the Home tab, Views panel, 

click . 

 

 
3. On the Results tab, Post Processing panel, open the ColorMap 

Configuration drop-down list and select Animation to view the post-

processing results in animation. 

To stop the animation: press <Esc> key. 

Design post-processing 

In the post-processing phase, once the corresponding calculations are 

performed, the results of the concrete / steel verifications can be viewed. 

Moreover, the concrete and steel members of the structure can be 

optimized using the functions provided by these design modules. 
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For this purpose, a set of specialized panels and commands are available, 

fully integrated within the same interface. 

 

  

Reinforced concrete results 

The reinforcement results on concrete elements (i.e., reinforcement area, 

buckling lengths, reinforcement ratios) are viewed using the Results tab, 

RC Design Results panel, which is available when the concrete 

calculation is completed. 

 
In the properties window of certain concrete elements (columns), the 

interaction curves issued from the reinforcement parameters, which are 

either determined automatically by the concrete module or set by the user, 

can be viewed. Therefore, it is possible to adjust, for example, a highly 

slender column exposed to oblique bending. 

 Example: Viewing the longitudinal reinforcement on beams 

1. Define a (-1, -1, 1) view of the workplane by pressing <Alt + 6>. 

2. In the project browser, select Portal frame > Beams system and 

press <Space>. 

3. On the Results tab, RC Design Results panel: 

-    Select the result type: Reinforcement. 

-    Select the result on linear elements: Az. 

-    Click  to perform the post-processing. 

The longitudinal reinforcement is automatically displayed as diagrams. The 

result values appear in the color legend displayed in the graphic area. 
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 Example: Viewing the reinforcement results on a column 

1. Select one column of the 

portal frame. 

2. In the element properties 

window, go to the Design Experts 

category - Reinforcement field. 

 

3. Click  to open the 

"Modification of longitudinal 

reinforcement" dialog box. The values 

of the real reinforcement and the 

calculated reinforcement for the 

selected column can be viewed. 

 

4. Click Interaction curves to access the 

interaction curves window. 

It is possible to view the position of the force 

component relative to the interaction area. For 

advanced visualization options, double click the 

diagram and the interaction curve is displayed in 

a new window. 

 

Steel results 

During the post-processing step, after the steel calculation, the steel expert 

module performs the verification of deflections, section's resistance, 

element's stability according to second order effects (buckling and lateral-

torsional buckling), and the optimization of steel shapes. 
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The steel results post-processing commands are available on the Results 

tab, Steel Design Results panel, once the steel calculation is done. 

 
The calculated buckling and lateral-torsional buckling parameters for each 

steel element can be viewed in the properties window. 

 

 Example: Verifying the steel elements stability 

1. On the Steel Design Results panel: 

-    Select the result type: Stability. 

-    Select the result: Work ratio. 

-    Click . 

2. Access the "Results" dialog box by 

pressing <Alt + Z>. 

3. Access the Options tab and select 

Extreme values. 

4. Click <OK>. 

 

    

 
 

Steel elements optimization 

The steel design module verifies the 

steel elements according to 

parameters specified by the global 

steel settings. 

The program identifies the steel 

shapes with a higher / lower work 

ratio than specified and suggests 

more appropriate cross sections. 
 

The suggested shapes can be accepted in whole or in part. Then, it is 

necessary to rerun the FE calculation and the structure optimization. 

These operations can be iterated until the appropriate work ratio is 

obtained for all steel shapes. 
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 Example: Optimization of steel shapes 

1. On the Results tab, Steel Design Results panel, click . The 

"Suggested shapes" dialog box appears. The steel sections with a work 

ratio out of the specified range are displayed in red. 

 
2. Click Accept all to accept the suggested shapes. 

3. Click <OK> to close and apply. 

4. Rerun the finite elements calculation and the steel calculation. 

After the calculation, open the "Suggested shapes" dialog box. If there are 

other suggested shapes, repeat the above steps until you obtain the work 

ratio comprised in the specified range for all steel shapes. 

Saved post-processing views 

A post-processing view saves the entire post-

processing scenario (i.e., result type, result 

component, selected analyses and elements, 

results visualization settings) together with the 

display settings of the model (i.e., view point, 

rendering, etc.). For each post-processing view, a 

corresponding image file is saved to disk. The 

saved images are in the Document mode of the 

project browser. 

Post-processing views automatically replay the 

saved post-processing, without having to 

manually recreate the post-processing scenario. 

Moreover, if the structure settings were changed 

and the results were modified, the updated post-

processing views display the new results. 
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 Example: Creating a post-processing view 

1. Define a (1, -1, 1) view of the workplane: press <Alt + 5>. 

2. Set a ghost display of the descriptive model: on the Home tab, 

Render Modes panel, click . 

3. Access the "Results" dialog box by pressing <Alt + Z>. On the FE 

tab, select: 

- Forces result type; 

- My result on linear elements; 

- Mxx result on planar elements; 

- 101 loads combination. 

4. Click <OK>. 

5. On the Results tab, click  to save the post-processing. 

 

  
 

 
 

To access a saved post-processing view: double click it in the project 

browser. 

Reports 

Advance Design provides an advanced and powerful report generator tool, 

with which the desired reports are easily defined. The available report 

templates can be used or new templates can be defined. The report 

generator filters its content according to the current settings and available 

results. At the same time, the report content takes the selection of 

elements (if any) into account. 
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 Example: Generating a report 

1. From the menu, select Documents > Standard Report; the report 

generator automatically loads the standard report template. 

 
2. On the Post-processing tab of the report generator, select the post-

processing view. 

3. In the report's content section, select the table with forces on planar 

elements and click  to insert the post-processing right below. 

 
 

4. Click Case / Combinations and select only combination 101 in the 

Displacements, Forces and Stresses tabs. 

5. Click Generate to start the report creation. When finished, the report 

is automatically displayed with the document viewer application. 
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DESIGN 

Starting with version 2017, Advance Design includes a new Project 

Browser mode called Design: 

 
Note: This mode is only available after the FEM analysis is completed. 

A corresponding Ribbon tab was consequently introduced: the Design 

ribbon, which only becomes active after an analysis is performed, and an 

element is selected in the Design tab of the Project Browser by double 

clicking on it. 

The Design tab of the Advance Design Ribbon provides you with access to 

commands from RC BIM Designers and Steel Connection Designer. 

 

You can achieve the entire design process within Advance Design:  
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Concrete elements 

Once the FEM analysis is complete, the user can open any element from 

the model by: 

 applying the new “Open with BIM Designers” command from the 

contextual menu: 

 

 by clicking on the “Design” tab in the Project Browser: 

 
Four types of concrete elements can be calculated using the Advance BIM 

Designers: footings (continuous and isolated), beams, columns and walls. 
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The unavoidable step before running a structural design session is to 

define the structural design assumptions.  

Structural design assumptions can be split in two different families: 

 Design codes assumptions (Design Settings) 
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 Constructive dispositions for the automatic placement of bars 

inside concrete members (Reinforcement Settings) 

 

Both assumption families (Design and Reinforcement) are country-code 

dependent (Eurocodes with different national appendixes, US codes, 

Canadian codes, NTC codes).  

When all assumptions are set, the user can calculate the model. Advance 

BIM Designers will automatically generate the reinforcement needed for 

the efforts transferred from Advance Design. 
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After the reinforcement is generated, the user still has the option to adjust 

it. The reinforcement can easily be modified or new bars can be added, 

with the possibility to see if the area of modified bars exceeds the 

theoretical area calculated by Advance BIM Designers. 

The calculated reinforcement can be restored at any point by using the 

“Restore from calculation” option.  
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Output: Calculation Results Tab 

For each performed verification, the "Calculation results" tab displays the 

verification type, combination, value, limit, and work ratio. 

 

Once the element is calculated, the user can display the drawing on 

screen, print it or save the drawing on the computer.  

On the drawing, the program automatically creates a bar schedule and a 

title block with all the information about the project and the element (this 

information will be imposed in “Drawing Settings” from Advance BIM 

Designers). 
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BIM Designer Reports  

One of the greatest features of Advance BIM Designers is producing a set 

of available reports.  

Users can preview reports using the Report Designer tool, or export them 

in DOC or PDF format. 

 

 

 


